To remediate this issue, users should upgrade to 4.0.3 or later.
Metrics
Affected Vendors & Products
No advisories yet.
Solution
No solution given by the vendor.
Workaround
No workaround given by the vendor.
Tue, 03 Nov 2026 20:30:00 +0000
| Type | Values Removed | Values Added |
|---|---|---|
| Metrics |
ssvc
|
Tue, 03 Nov 2026 19:00:00 +0000
| Type | Values Removed | Values Added |
|---|---|---|
| Description | Cross-site scripting (XSS) issue in AWS Amplify maplibre-gl-js-amplify before 4.0.3 might allow remote authenticated users to inject arbitrary web script or HTML via the (1) title, (2) address, or (3) place_name property in GeoJSON feature data rendered by popupRender, or the (4) geofenceId value rendered in AmplifyGeofenceControl. To remediate this issue, users should upgrade to 4.0.3 or later. | |
| Title | Stored cross-site scripting (XSS) in AWS Amplify maplibre-gl-js-amplify popup rendering | |
| First Time appeared |
Aws
Aws maplibre-gl-js-amplify |
|
| Weaknesses | CWE-79 | |
| CPEs | cpe:2.3:a:aws:maplibre-gl-js-amplify:*:*:*:*:*:*:*:* | |
| Vendors & Products |
Aws
Aws maplibre-gl-js-amplify |
|
| References |
| |
| Metrics |
cvssV3_1
|
Projects
Sign in to view the affected projects.
Status: PUBLISHED
Assigner: AMZN
Published:
Updated: 2026-11-03T20:01:00.960Z
Reserved: 2026-11-03T18:17:51.751Z
Link: CVE-2026-121652
Updated: 2026-11-03T20:00:54.283Z
Status : Received
Published: 2026-11-03T19:18:05.363
Modified: 2026-11-03T20:18:13.460
Link: CVE-2026-121652
No data.
OpenCVE Enrichment
Updated: 2026-11-03T21:15:03Z