IBM CockroachDB PostgreSQL for IBM VPC 26.2.0 through 26.2.3, 25.4.0 through 25.4.12, and 25.2.0 through 25.2.20 is vulnerable to privilege escalation via user-defined function.
Advisories

No advisories yet.

Fixes

Solution

For CockroachDB PostgreSQL for IBM VPC, upgrade to CockroachDB 25.2.20, 25.4.12 or 26.2.3. Download the product versions from IBM Passport Advantage Online.


Workaround

No workaround given by the vendor.

History

Sun, 08 Nov 2026 18:30:00 +0000

Type Values Removed Values Added
Description IBM CockroachDB PostgreSQL for IBM VPC 26.2.0 through 26.2.3, 25.4.0 through 25.4.12, and 25.2.0 through 25.2.20 is vulnerable to privilege escalation via user-defined function.
Title CockroachDB PostgreSQL for IBM VPC is affected by multiple vulnerabilities
First Time appeared Ibm
Ibm cockroachdb Postgresql For Ibm Vpc
Weaknesses CWE-269
CPEs cpe:2.3:a:ibm:cockroachdb_postgresql_for_ibm_vpc:25.2.0:*:*:*:*:*:*:*
cpe:2.3:a:ibm:cockroachdb_postgresql_for_ibm_vpc:25.2.20:*:*:*:*:*:*:*
cpe:2.3:a:ibm:cockroachdb_postgresql_for_ibm_vpc:25.4.0:*:*:*:*:*:*:*
cpe:2.3:a:ibm:cockroachdb_postgresql_for_ibm_vpc:25.4.12:*:*:*:*:*:*:*
cpe:2.3:a:ibm:cockroachdb_postgresql_for_ibm_vpc:26.2.0:*:*:*:*:*:*:*
cpe:2.3:a:ibm:cockroachdb_postgresql_for_ibm_vpc:26.2.3:*:*:*:*:*:*:*
Vendors & Products Ibm
Ibm cockroachdb Postgresql For Ibm Vpc
References
Metrics cvssV3_1

{'score': 7.1, 'vector': 'CVSS:3.1/AV:L/AC:L/PR:L/UI:N/S:U/C:H/I:H/A:N'}


Projects

Sign in to view the affected projects.

cve-icon MITRE

Status: PUBLISHED

Assigner: ibm

Published:

Updated: 2026-11-08T18:08:42.430Z

Reserved: 2026-08-04T19:50:01.095Z

Link: CVE-2026-18893

cve-icon Vulnrichment

No data.

cve-icon NVD

No data.

cve-icon Redhat

No data.

cve-icon OpenCVE Enrichment

No data.

Weaknesses